F.Ko-Jiの「一秒後は未来」

CentOSにyumをインストールする

ちょっとメモ書き。CentOSにyumをインストールする方法です。かなり真っさらな状態のOSに入れています。

まずOSのバージョンを調べます。

% cat /etc/redhat-release
CentOS release 5.4 (Final)

今回はCentOS 5.4を前提で説明。あとunameでシステム情報を見ておきます。

uname -a
Linux xxxxxx.xx 2.6.18-028stab068.5 #1 SMP Fri Mar 12 13:55:49 MSK 2010 i686 i686 i386 GNU/Linux

i386とあるので http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/ からyumのrpmを取ってきます。

% cd /usr/local/src
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/yum-3.2.22-20.el5.centos.noarch.rpm

別のバージョン、アーキテクチャの場合はURLを遡って見つけてください。

とりあえずインストールしてみます。

% rpm -ivh yum-3.2.22-20.el5.centos.noarch.rpm 
warning: yum-3.2.22-20.el5.centos.noarch.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
	python-elementtree is needed by yum-3.2.22-20.el5.centos.noarch
	python-iniparse is needed by yum-3.2.22-20.el5.centos.noarch
	python-sqlite is needed by yum-3.2.22-20.el5.centos.noarch
	rpm-python is needed by yum-3.2.22-20.el5.centos.noarch
	urlgrabber >= 3.1.0 is needed by yum-3.2.22-20.el5.centos.noarch
	yum-fastestmirror is needed by yum-3.2.22-20.el5.centos.noarch
	yum-metadata-parser >= 1.1.0 is needed by yum-3.2.22-20.el5.centos.noarch

エラー。必要なパッケージがリストされてるのでダウンロードします。

% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/python-elementtree-1.2.6-5.i386.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/python-iniparse-0.2.3-4.el5.noarch.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/python-sqlite-1.1.7-1.2.1.i386.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/rpm-python-4.4.2.3-18.el5.i386.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/python-urlgrabber-3.1.0-5.el5.noarch.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/yum-metadata-parser-1.1.2-3.el5.centos.i386.rpm

再チャレンジ。

% rpm -ivh *
warning: python-elementtree-1.2.6-5.i386.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
	m2crypto >= 0.16-5 is needed by python-urlgrabber-3.1.0-5.el5.noarch
	libxml2.so.2 is needed by yum-metadata-parser-1.1.2-3.el5.centos.i386

まだダメ。

% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/m2crypto-0.16-6.el5.6.i386.rpm
% wget http://mirror.centos.org/centos-5/5.4/os/i386/CentOS/libxml2-2.6.26-2.1.2.8.i386.rpm

これでようやく揃ったようで、

% rpm -ivh *

を実行してyumがインストールできました。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

著者について

fkoji

F.Ko-Ji

Webエンジニアやってます。最近は ドットインストール の開発がお仕事です。その傍ら、個人で Meity電車遅延なう梅酒.in#グラドル自画撮り部 の部室といったネットサービスを開発・運営してます。梅酒と草野球とリアル脱出ゲームが好きです。

» 詳しいプロフィールや運営サービスの一覧など